[curves] Curve25519 naming / renaming
David Leon Gil
coruus at gmail.com
Wed Aug 27 05:30:16 PDT 2014
On Tuesday, August 26, 2014, Trevor Perrin <trevp at trevp.net> wrote:
> Dealing with an "X25519" function that is the same as the old
> "Curve25519", but not necessarily compatible with uses of the new
> "Curve25519", seems unnecessarily confusing.
> So while clarifying the names here is a great idea, it seems better
> not to change the name from its most common use.
(Very much agree; the situation seems to be even worse for "P-25519",
Ed25519, Ed25519-SHA2, and EdDSA, which no one seems to understand the
Microsoft's naming convention actually makes some sense; they've named the
curves by the *least* common isomorphic form. But I'd kind of like to see
new curve names incorporate more information about the *curve*, rather than
just prime field and form. (Perhaps encoding that some parameter is
minimal, for rigid curves?)
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Curves