[noise] Extensions for forward secrecy and New Hope

Brian Smith brian at briansmith.org
Sat Aug 27 16:58:49 PDT 2016

Rhys Weatherley <rhys.weatherley at gmail.com> wrote:
> Additional forward secrecy:
> https://github.com/rweather/noise_spec/blob/forward_secrecy/extensions/ext_forward_secrecy.md

Currently protocol names are valid Rust (and other language)
identifiers, which may be useful for some implementation(s). Adding
"+" to the naming would mean that we can't use protocol names as
identifier names in programs. It would be nice to find another scheme
that avoids this issue. Perhaps instead of "25519+448" one could do
something like "25519_fs448".

Another problem with the suggested naming scheme is that it might get
confusing if/when signature-based schemes are added. 25519+25519 Could
be X25519+Ed25519 or X25519+X25519, I guess.


More information about the Noise mailing list