[noise] minor suggestion: pre-message pattern instead of pre-message patternS ?

David Wong davidwong.crypto at gmail.com
Wed Nov 1 10:55:43 PDT 2017

Sorry for the spam today :)

a handshake pattern is:

* a pre-message pattern for the initiator
* a pre-message pattern for the responder
* a sequence of message patterns for the actual handshake messages
(called a handshake pattern?)

Just two minor suggestions (btw, are the issues on github a better
place for that?):

1. the two pre-message patterns could be merged into one pre-message
pattern where the responder tokens are represented as "rs" and "re". I
know this would make the diagrams less nice, but this would make the
code nicer.

2. a handshake pattern has a handshake pattern inside of it. Maybe
renaming one of the handshake pattern would be a good idea? In my
implementation I currently renamed a handshake pattern with "a
handshake type" which includes pre-message patterns and a handshake


More information about the Noise mailing list