[noise] minor suggestion: pre-message pattern instead of pre-message patternS ?

David Wong davidwong.crypto at gmail.com
Thu Nov 2 03:59:38 PDT 2017

> I believe the "sequence of message patterns" is just called that
> ("sequence of message patterns"), in the spec.
> The term "handshake pattern" refers to the whole thing: A sequence of
> pre-message patterns followed by a sequence of message patterns.
> Maybe you think this is confusing because the Overview says "Message
> patterns are arranged into handshake patterns"?  That's admittedly a
> loose explanation, but that seems OK for the Overview, since
> pre-message patterns haven't been introduced yet.

I see! That makes it clearer for me. This is the struct I created for
my implementation:

type handshakePattern struct {
name                         string
preMessagePatterns []messagePattern
messagePatterns      []messagePattern

with the first message pattern of pre-message patterns being the
initiator pre-message pattern, and
the second message pattern of pre-message patterns being the responder
pre-message pattern.

I think this makes it more consistent with the message patterns.


More information about the Noise mailing list